
Rename File Window
WavSorter displays the Rename File window when you select a file in the File listbox, and 
select Rename from the File menu.
The current name of the file is displayed here; edit it to change the name of the file 
(remember that DOS filenames consist of a maximum of eight characters, a period (.), and a 
three-letter extension).
Click Rename to rename the file, or click Cancel to skip it.



Rename Directory Window
WavSorter displays the Rename Directory window when you select a directory in the 
Directory listbox, and select Rename from the File menu.
The current name of the directory is displayed here; edit it to change the name of the 
directory (remember that DOS directory names consist of a maximum of eight characters, a 
period (.), and a three-letter extension, just like filenames).
Click Rename to rename the directory, or click Cancel to skip it.



Create Directory Window
WavSorter displays the Create Directory window when you select a directory in the Directory
listbox, and select Create Directory from the File menu. When you create a new directory, 
you'll create it as a subdirectory of the selected directory.
The name of the directory you selected is shown in the top box. Enter the name of the new 
directory in the lower box.
Click OK to create the new directory, or click Cancel to skip it.



Delete Directory Window
WavSorter displays the Delete Directory window when you select a directory in the Directory
listbox, and select Delete Directory from the File menu.
This window displays the name of the directory you selected. Double-check the name, and 
either click OK to proceed or click Cancel to skip it.



Directory Not Empty Window
WavSorter displays the Directory Not Empty window when you try to delete a directory that 
has files in it. This is a safety feature, since deleting a directory also means deleting the files 
in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done (and 
WavSorter will remind you with yet another message).



Folder Not Empty Window
WavSorter displays the Folder Not Empty window when you try to delete a folder (which 
represents a directory) that has files in it. This is a safety feature, since deleting a directory 
also means deleting the files in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory 

represented by the folder.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done (and 
WavSorter will remind you with yet another message).



Create File Association Window
WavSorter Pro Feature!

WavSorter displays the Create File Association windows when you select Windows File 
Association from the Edit menu. It lets you create or change a Windows file association.



Assign System Sounds Window
WavSorter Pro Feature!

WavSorter displays the Assign System Sounds window when you select Windows System 
Sounds from the Edit menu. It lets you change the sounds Windows associates with certain 
system events.



Warning Window
WavSorter displays this window when you try to delete a folder (which represents a 
directory) that has files in it. This is a safety feature, since deleting a directory also means 
deleting the files in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done (and 
WavSorter will remind you with yet another message).



Edit Folder Window
This window lets you create or change a folder's label, and assign or reassign the directory it 
represents; or clear a folder (make it turn gray). 
Setting Up an Empty (Gray) Folder
Changing a Folder's Directory Assignment
Changing Only a Folder's Label
Clearing a Folder (Making it Turn Gray)

See Also: Working with Folders



Setting Up an Empty (Gray) Folder
· Select a directory in the Directory listbox. Hold down the Shift key and drag the directory

name to a gray folder, and drop it.
Or:

· Select a directory in the Directory listbox. Click on a gray folder; it will be highlighted. 
Then select Folder from the Edit menu.

WavSorter displays the Edit Folder Window. The Current box will be empty, because this 
folder hasn't been set up yet. The New box shows the directory you selected in the Directory 
listbox.
If you want to select a different directory to assign to the folder, click Browse. WavSorter 
displays a dialog box that lets you select a new drive and directory. When you've done that, 
click OK in that dialog box to return to the Edit Folder Window.
Type a label for the folder in the Label box. Labels can be no more than eight characters 
long.
Press Enter, or click OK. The folder will turn blue, indicating that it's been set up.



Changing a Folder's Directory Assignment
If you want to change the directory assigned to a folder:
· Select a directory in the Directory listbox. Hold down the Shift key and drag the directory

name to the blue folder you want to change, and drop it.
Or:

· Click on the blue folder; it will be highlighted. Then select Folder from the Edit menu.
WavSorter displays the Edit Folder Window. The Current box shows the directory currently 
assigned to the folder. The New box shows the directory you selected in the Directory 
listbox.
If you want to select a different directory to assign to the folder, click Browse. WavSorter 
displays a dialog box that lets you select a new drive and directory. When you've done that, 
click OK in that dialog box to return to the Edit Folder Window.
If you also want to change the folder's label, type the new label for the folder in the Label 
box. Labels can be no more than eight characters long.
Press ENTER, or click OK.



Changing Only a Folder's Label
Select the folder by clicking on it, then select Folder from the Edit menu. WavSorter displays 
the Edit Folder Window. Type the new label in the Label box, then press ENTER, or click 
OK.



Clearing a Folder (Making it Turn Gray)
You can also use the Edit Folder Window to clear a folder; this means that it will no longer 
have a directory assigned to it, nor will it have a caption.
Click on a blue folder; it will be highlighted. Then select Folder from the Edit menu.
WavSorter displays the Edit Folder Window. Click Clear Folder; WavSorter sets the 
directory and label to blank. Then press ENTER, or click OK to officially clear the folder; or,
if you change your mind, just click Cancel.



Duplicate Files Window
If, while copying or moving a file, you encounter a file at the destination with the same name
as the one you are copying or moving, the operation is halted and WavSorter displays the 
Duplicate File Names window. 
The file you want to copy or move (called the "source" file) appears on the left, the file with 
the same name at the destination (called the "target" file) appears on the right. 
WavSorter displays the statistics and directory of both files, to give you one basis for 
comparing the two. Another way to compare the files is to click either file's Listen button, to
play the files.
You have several options in this window for how to proceed:
· Click the Replace button to delete the target file and copy or move the source file to the 

destination.
· Click the Rename button to open the Rename File window, enter a new name for the 

source file, and press ENTER or click OK. The source file will be renamed and copied or 
moved to the destination.

· Clicking the Delete button will delete the source file from the source directory, and then 
continue.

· Click Skip to skip the operation for this file, and continue with any files remaining in the 
operation.

· Click Cancel to abort the entire operation; any files remaining to be copied or moved 
won't be, but (of course) files copied or moved previously stay that way (this isn't an 
Undo button).

Hint: Right-click on the file name for the complete path of the file.



File Statistics
Provides information about file size, date and time last saved or changed, and attributes 
(hidden, system, readonly, normal, and archive).

See: Displaying File Statistics



Directory Statistics
Provides information about the size of the currently-selected directory, and the number of 
files contained in that directory.

See: Displaying Directory Statistics



Create Directory
Lets you create a new directory under the currently-selected directory.

See: Creating a Directory



Delete Directory
Deletes the selected directory.

See: Deleting a Directory



Rename File
Opens a window for renaming the selected file.

See: Renaming a File



Rename Directory
Opens a window for renaming the selected directory.

See: Renaming a Directory



Exit
Clicking on this exits WavSorter. If you've changed your configuration and haven't saved the 
changes to a configuration file, WavSorter will ask you if you want to save your 
configuration.



Edit Folder
This item displays a window in which you assign a directory and a label to folders, or clear a 
folders label and directory assignment.

See: Working with Folders
Edit Folder Window



Edit Custom Toilet Sound
This item displays a dialog box in which you select a custom sound WavSorter will use when
deleting. WavSorter will use your file when you select Custom Toilet Sound under the Sound 
Effects item on the Options menu.

See: Toilet (Deletion) Sound Effect Options



Edit Custom Launch Sound
This item displays a dialog box in which you select a custom sound WavSorter will use when
launching a file. WavSorter will use your file when you select Custom Launch Sound under 
the Sound Effects item on the Options menu.

See: Launch Sound Effect Options



Edit Windows System Sounds
WavSorter Pro Feature!

Yes indeed, with WavSorter Pro you can assign system sounds from within WavSorter. Nice 
touch.

See: Assigning System Sounds



Edit Custom Drag/Drop Icon
Displays a dialog box for choosing and assigning your own icon for drag and drop 
operations.

See: Assigning Drag Icons



Edit Windows File Association
WavSorter Pro Feature!

Opens a window for associating a file extension with an .EXE, .COM, .BAT, or .PIF file. 
See: Associating a File

Launching Files



Toilet Sound Effect

These three items control the sound effect associated with deleting something. Only one of the 
three items can be selected at a time; the one that's selected is checked. Check an item by 
selecting it from the menu.
See: Toilet (Deletion) Sound Effect Options



Launch Sound Effect

These three items control the sound effect associated with launching a file. Only one of the three 
items can be selected at a time; the one that's selected is checked. Check an item by selecting it 
from the menu.
See: Launch Sound Effect Options



Message Box Sounds

WavSorter can use the Windows system event sounds as a sound effect to accompany the various
message dialog boxes it displays. Select Message Box Sound Off or Message Box Sound
On to control whether WavSorter uses these sounds.
See: System Event Sounds



Drag Icon Options

These four items select the icon used during drag operations. Only one of the four items can be 
selected at a time; the one that's selected is checked. Check an item by selecting it from the 
menu.
See: Configuring Drag Icons



Confirm Deletes
If this item is checked, you will be prompted for confirmation before a file is deleted. Toggle 
this item on and off by clicking on it. By default, Confirm Deletes is always on when you 
start WavSorter.

See: Deleting a File
Deleting a Directory
Deleting the Contents of a Folder



Show Size in KB
If this item is selected, file size and directory size will be displayed in kilobytes. Otherwise, 
size is displayed in bytes. Toggle this item on and off by clicking on it.

See: File Statistics
Directory Statistics



Show Sound Queue
This option controls whether WavSorter displays a window showing the sound queue while 
its playing files. The Sound Queue Window shows the files in the queue, and the file 
currently playing.

See: Playing the Contents of a Folder
Playing the Files in a Directory
Configuring WavSorter



Default Drag/Drop Operation
The third-level menu items Copy and Move control which type of operation is performed by 
a drag-and-drop. You can override the default by holding down the Ctrl key while you drag 
(if the default is move, it becomes copy; if the default is copy, it becomes move)..

See: Default Drag Operation



Load Configuration
WavSorter Pro Feature!

Opens a dialog box for selecting and then loading a stored configuration.
See: Managing Configurations

Configuring WavSorter



Save Current Configuration
Saves your current configuration to disk, so that it can be used next time you start WavSorter.

WavSorter Pro Feature! WavSorter Pro can store multiple 
configurations.

See: Configuring WavSorter



Save Current Configuration As
WavSorter Pro Feature!

Displays a dialog box for saving your current configuration under a name other than the one 
you are now using.

See: Managing Configurations
Configuring WavSorter



New Configuration
WavSorter Pro Feature!

This item resets all the settings in WavSorter to their defaults, and empties all the folders 
(makes them grey, or not set up; it doesn't do anything to their assigned files or directories). 
This is useful to make WavSorter a "blank slate" for you to start a new configuration.

See: Managing Configurations
Configuring WavSorter



Contents
WOW!! A complete help system! If you've ever written help files, you'll appreciate that on-
line, context-sensitive help is not a trivial feature. Clicking on this item opens the help 
window and provides you with a list of WavSorter help topics.

See: Help Contents



Search
Opens a dialog box for searching WavSorter help. Works very much like using an index.



Magic Target Help
Well, you've come full-circle: you're using Magic Target Help right now. Cool, huh? Leave 
me a message and let me know what you think.
Oh, by the way: if you're trying to turn off Magic Target Help, click on the box labeled "Click
here when down with MT help." You're welcome.

See: Using Magic Target Help



Getting Started
This item provides an overview of WavSorter, a quick start guide, and a description of 
WavSorter Pro.

See: Getting Started



Shortcuts and Techniques
Want shortcuts and techniques? After spending many hundreds of hours developing this 
program, I've become quite familiar with the interface. Besides, I wrote it...

See: Shortcuts and Techniques



WavSorter Pro
When you register, you'll receive WavSorter Pro. Click on this item to find out about the 
awesome, amazing features available in WavSorter Pro.

See: WavSorter Pro



Registration
I know, I know, WavSorter Pro is already a great value at only $24.00 but I'm generous to a 
fault. Click on this item to find out about the other benefits available to registered owners.

See: Registering WavSorter



Register
THANK YOU! Clicking this item opens a window for ordering WavSorter Pro. You simply 
type in the information and click on "Print Order" to print out your order. Enjoy!
REGISTER NOW!



About WavSorter
Displays information about WavSorter, including version number.



FileName Panel
When you select a file, WavSorter displays its complete path in this box.



Configuring WavSorter
You control how WavSorter 
works with items on the 
Options menu (one exception is
your selection for the type of 
file displayed, which is 
controlled by the File Type 
controls).

WavSorter remembers your configuration, so that your selections will be used the next time 
you run WavSorter. If you have the registered version, WavSorter Pro, you can keep multiple 
configurations.

Sound Effects are the sounds associated with WavSorter's deletion and file-launching 
operations.
Icons are the mouse pointers used during drag and drop operations.
Confirm Deletes controls whether WavSorter asks you if you're sure when you tell it to delete 
something.
Show Size in KB determines the format in which WavSorter displays the size of files. If it's 
checked, WavSorter uses kilobytes (KB, or multiples of 1024 bytes); if it's not checked, 
WavSorter displays file sizes in bytes.
Show Sound Queue controls whether WavSorter pops up a window displaying the sound 
queue when you're playing sound files.
Default Drag/Drop Operation determines whether moving or copying is the action 
performed by dragging.
Configuration has several commands that let you save your current configuration, and (if you 
have WavSorter Pro) manage multiple configurations.
Also, the File Type controls provide a file extension filter, which determines what kinds of files 
WavSorter lists in the File listbox.



Configuring Sound Effects

This item selects the sound effect associated with WavSorter operations:
· Deletion, when you use the Delete   button   (by default accompanied by the toilet sound)
· File launching, when you use the Launch   button  .
· Message Box Sounds, the sound effect that accompanies a dialog box containing a 

message from WavSorter.
In each section, only one of the items can be selected (checked) at a time. You select an item 
by simply selecting the menu item.



Toilet (Deletion) Sound Effect Options

These three items control the sound effect associated with deleting something. Only one of the 
three items can be selected at a time; the one that's selected is checked. Check an item by 
selecting it from the menu.
Toilet Sound Off means that no sound effect will be associated with deleting.
Default Toilet Sound means that you'll hear the sound of your file hitting the water when you 
drop it in the toilet (especially gratifying if it's a large file you paid long-distance charges to 
download, then felt ripped off).
Custom Toilet Sound selects the custom delete sound you selected with Custom Toilet Sound 
on the Edit menu. WavSorter copies the selected file to the WavSorter program directory, and 
gives you the option of deleting the old custom sound file.



Launch Sound Effect Options

These three items control the sound effect associated with launching a file. Only one of the three 
items can be selected at a time; the one that's selected is checked. Check an item by selecting it 
from the menu.
Launch Sound Off means that no sound effect will be associated with launching.
Default Launch Sound selects the sound of a car starting.
Custom Launch Sound selects the custom launch sound you selected with Custom Launch 
Sound on the Edit menu. WavSorter copies the selected file to the WavSorter program directory, 
and gives you the option of deleting the old custom sound file.



Message Box Sound Effect Options

WavSorter can use the Windows system event sounds as a sound effect to accompany the various
message dialog boxes it displays. Select Message Box Sound Off or Message Box Sound
On to control whether WavSorter uses these sounds.



Configuring Drag Icons

These four items select the icon used during drag and drop operations. Only one of the four items
can be selected at a time; the one that's selected is checked. Check an item by selecting it from 
the menu.

Doggie Icon selects Socrates the dog, who will faithfully carry your files and objects to their 
destinations.
Spaceship Icon selects a spaceship.
Custom Icon uses the icon you selected with the Custom Drag/Drop Icon on the Edit menu.
Default Icon selects a more conservative icon.



Default Drag Operation
The default drag operation is the one which does not require holding down the Ctrl key when 
you start the drag. You can specify whether you want move as the default or copy, using the 
Default Drag/Drop Operation item on the Options menu.
This item has a third-level menu, listing the choices Move or Copy. The current default is 
indicated by a check mark; only one can be checked at a time. The one you select becomes 
the current (checked) default.

 Select Copy to make it the default.

 Select Move to make it the default



Confirm Deletes
If the Confirm Deletes item on the Options Menu is checked, you will be prompted for 
confirmation before a file is deleted. Toggle this item on and off by clicking on it. By default,
Confirm Deletes is always on when you start WavSorter.



Managing Configurations

WavSorter stores your configurations in a file in the WavSorter program directory. If you've 
made changes and then try to exit WavSorter, you'll first be asked whether you want to save your
current configuration. WavSorter displays the name of your current configuration file in the 
caption.

Only Save Current is available in the evaluation version of WavSorter; it saves your 
current configuration in the current configuration file. You can maintain only one 
configuration in this version.

WavSorter Pro Feature!
In addition, WavSorter Pro can store and load multiple configurations.

See: Using Multiple Configurations for more information.



Using Multiple Configurations
WavSorter Pro Feature!

A central concept of WavSorter is that you should be allowed to customize the interface to 
suit your own personality and style of working. Furthermore, you should be allowed to 
customize WavSorter for a variety of tasks and uses.
To suit your own personality and style, WavSorter gives you choices about how it operates, 
and remembers your preferences in a configuration file. You can:
· Position WavSorter windows on the screen, and have WavSorter put them in the same 

place next time you use them;
· Choose the drag icon you want to use, either from choices provided by WavSorter, or a 

graphic file you specify;
· Specify whether or not to use sound effects; and choose from the sound effects WavSorter

provides, or specify your own;
· Specify whether WavSorter show sizes in bytes or kilobytes (KB) when displaying file 

statistics;
· Specify whether WavSorter asks you to confirm deletes;
· Customize folders, by assigning directories to them and attaching labels;
· Choose between move or copy as the default drag operation.

As a result, you can create multiple configurations of WavSorter, each customized for a 
specific task. For example, you might have one configuration for sorting wav files, another 
for MIDI files, and maybe one to serve as a jukebox. Heck, you can even create 
configurations for non-sound files. Sort documents, text files, database files, spreadsheets, or 
any other type of files you want. I'm sure there are many other uses for WavSorter. If you 
think of one, send me a message. Thanks.

See: Multi-stage sorting



File Extension Filter
A "file extension filter" is a DOS filename pattern, such as *.WAV, that filters out all 
filenames that don't match the pattern. In the example, the asterisk (*) means "any characters 
in the first eight positions of the filename," while the .WAV part means that the last three 
letters (the extension) must be WAV.
In WavSorter, setting the file extension filter controls the files displayed in the File listbox. 
You set the filter with the File Type controls.
There are two ways to set the file extension filter:
· Click on the arrow next to the File Type box, select the extension you want from list, and 

press Enter.
Or:

· In the file type box, type the extension you want and then press Enter.



Working with Directories
Creating a Directory
Renaming a Directory
Deleting a Directory
Copying the Contents of a Directory
Moving the Contents of a Directory
Playing the Files in a Directory
Displaying Directory Statistics



Creating a Directory
In the Directory listbox, click on either the drive letter (e.g., "c:\") or the directory under 
which you want the new one. Select Create Directory... on the File Menu and the Create 
Directory window will appear. Enter the name you want for the new directory and then press 
ENTER or click OK.



Renaming a Directory
Select the directory you want to rename by clicking on it in the Directory listbox. Chose 
"Rename Directory..." on the File Menu and the Rename Directory window will appear. 
Enter the new name for the directory and then press ENTER or click on the OK button.



Deleting a Directory
You have a choice of two ways to delete a directory:
1. Select the directory you want to delete by clicking on it in the Directory listbox and then 

click the Delete   button   to delete the directory.
Or
2. Drag the directory to the Delete button and drop it on the button.
If the directory contains files, you will be asked if you want to proceed. If you want to 
proceed, you will be given a choice of either confirming the deletion of each file or deleting 
all the files in the directory without confirmation.

Hint: Since you can confirm the deletion of each file, this is handy way of "weeding" out 
unwanted files. Simply click Yes to delete a file you don't want; click No to keep a file 
you do want.



Copying the Contents of a Directory
You can drag a directory from the Directory listbox into a folder, to copy the files in the 
directory into the directory represented by the folder. Note that you can't drag files into a 
folder whose directory is the same as the source of the files (naturally).
The default drag operation setting on the Options menu affects how you drag directories. 
When you want to copy, it works like this:
· If the default operation is copy, then simply drag the directory.
· If the default operation is move, then hold down the Ctrl key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Moving the Contents of a Directory
You can drag a directory from the Directory listbox into a folder, to move the files in the 
directory into the directory represented by the folder. Note that you can't drag files into a 
folder whose directory is the same as the source of the files (naturally).
The default drag operation setting on the Options menu affects how you drag directories. 
When you want to move, it works like this:
· If the default operation is move, then simply drag the directory.
· If the default operation is copy, then hold down the Ctrl key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Playing the Files in a Directory
You have a choice of two ways to play the sound files in a directory:
1. In the Directory listbox, select the directory you want to play by clicking on it and then 

click the Play Directory   button  .
Or
2. Drag the directory to the Play Directory button and drop it on the button.

WavSorter Pro Feature! Note: Only WavSorter 
Pro can play MIDI files.

WavSorter will play, in alphabetical order, all the sound files in the directory. You can stop 
play at any time by clicking the Stop   button  . Unlike individual files, you must wait until one 
directory is finished playing before starting play of another one. Note that files will play in 
the background, which means you can continue working on other things--even minimize 
WavSorter--while a directory is playing. However, it's best to avoid copying, moving, or 
deleting a file waiting to be played since WavSorter then won't be able to find the file.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it. However, if you have a lot 
of files in the directory you play, you may seriously tie up your computer. To prevent this, 
WavSorter stops trying after the fifth bad file.



Displaying Directory Statistics
First, select a directory by single-clicking on it in the Directory listbox. Then either click on 
the "Directory Statistics..." item on the File Menu, press F3, or right-click on the directory. A 
message box will pop up with information about directory size and the number of files 
contained in that directory.



Working with Files
Playing a File
Launching a File
Copying a File to a Folder
Moving a File
Deleting a File
Renaming a File
Assigning System Sounds
Associating a File
Duplicate Files Window
Editing a Sound File
File Statistics



Playing a File
There are three ways to play a file:
1. Select a file by clicking on it in the File listbox, then click the Play File   button  .
2. Drag a file to the Play File   button   and drop it on the button.
3. Double-click on a file in the File listbox.

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

There is no need to wait for a file to finish playing; you can continue choosing files in any of 
the three manners described above while a file is playing. The files will be played in the 
order they were chosen. It's best to avoid copying, moving, or deleting a file waiting to be 
played since WavSorter then won't be able to find the file. Note that if you click the Stop     
button, the queue will be cleared.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it.



Launching a File
Once you've associated a file extension with an application, you can launch that file by either
clicking on the file in the File listbox to select it and then clicking the Launch   button  , or you 
can drag the file to the Launch button and drop the file on the button.

Hint 1:You can launch more than one file at a time. Each application or instance of the same 
application will have the selected file for that application or instance already loaded.

Hint 2:Applications which have been started by launching work independently of WavSorter. 
They will remain open until you close them, even after you've exited from WavSorter.



Copying a File to a Folder
Copy files to folders by dragging filenames from the File listbox and dropping them on a 
folder.
The default drag operation setting on the Options menu affects how you drag files. When you
want to copy, it works like this:
· If the default operation is copy, then simply drag the file.
· If the default operation is move, then hold down the CTRL key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Moving a File
You move files to folders by dragging filenames from the File listbox and dropping them on a
folder.
The default drag operation setting on the Options menu affects how you drag files. When you
want to move, it works like this:
· If the default operation is move, then simply drag    the file.
· If the default operation is copy, then hold down the CTRL key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Deleting a File
You can delete a file using one of two methods:
· Select the file you want to delete by clicking on it in the File listbox. Click the Delete     

button to delete the file.
· Drag the file you want to delete to the Delete   button   button and drop it on the button.



Renaming a File
To rename a file:
1. Select the file you want to rename by clicking on it in the File listbox.
2. Press F4, or from the File Menu, select "Rename File..."
3. In the Rename File window, enter the new name for the file.
4. Press Enter, or click Rename to rename the file to the new name.



Assigning System Sounds
WavSorter Pro Feature!

You can tell Windows to play a sound file when certain system events take place. You could 
do this through the Windows Control panel; but it's a lot more convenient to do this from 
right inside WavSorter.



Associating a File
WavSorter takes advantage of file associations with the Launch   button  ; it gives Windows the
name of the file you've selected, and relies on Windows to find the associated application.

WavSorter Pro Feature!
Further, you can edit existing file associations, or create new ones, from within WavSorter 
Pro--you don't have to go to File Manager. You'd do this with the Windows File Association...
item on the Edit menu.



Editing a Sound File
Once you have associated your sound files with a sound editor, you can launch the editor to 
edit a selected sound file. There are two ways to do this:
· Click on the filename in the File listbox and then click the Launch   button  .
· Drag the filename from the File listbox to the Launch   button  , and drop it on the button. 

If you're not familiar with the concept of associating file extensions, see pages 130-132 of 
your Windows 3.1 User's Guide. 

Hint: You can very easily associate file extensions from within WavSorter; there's no need to 
use File Manager to do it.

See: Associating a file
Launching a file



Displaying File Statistics
WavSorter can display information about the size of a file, the date and time it was last 
changed or saved, and its current attributes.
1. Select a file by clicking on it in the File listbox. 
2. Either select File Statistics... from the File Menu, press F2, or right-click on the file. 
WavSorter displays a message box with the file information.

Hint: The "archive" attribute is particularly useful when sorting because it tells you whether 
the file has changed since the last time it was backed up. If you see the archive attribute 
listed for a file, it means the file has changed since it was last backed up.



Working with Folders
Overview
Playing the Contents of a Folder
Copying the Contents of a Folder
Moving the Contents of a Folder
Deleting the Contents of a Folder
Edit Folder Window
Folder Statistics



Folder Overview
The central concept of a folder is that it represents a directory on your disk drive. When you 
copy or move a file to a folder, you are actually copying or moving the file to the directory 
assigned to that folder. More importantly, when you delete a file from a folder, you are 
deleting that file from the assigned directory. 
This probably seems obvious but while I was developing WavSorter, I occasionally found 
myself deleting a file from a folder and thinking I was only removing it from that particular 
folder. Of course, in reality, the file was toast....gone. Similarly, when you copy or move a 
folder's contents from one folder to another, you are copying or moving the files from one 
directory to another.
Folders come in two colors, and various appearances (click here), and change appearance as 
you interact with them.



Playing the Contents of a Folder
There are two ways to play the sound files in a folder:
· Select the folder you want to play by clicking on it and then click the Play Directory     

button (you are, after all, playing the directory assigned to that folder).
Or
· Drag the folder to the Play Directory button and drop it on the button.

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

WavSorter will play, in alphabetical order, all the sound files in the folder. You can stop play 
at any time by clicking the Stop   button  . Unlike individual files, you must wait until one 
folder is finished playing before starting play of another one. Note that files will play in the 
background, which means you can continue working on other things--even minimize 
WavSorter--while a folder is playing.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it. However, if you have a lot 
of files in the directory you play, you may seriously tie up your computer. To prevent this, 
WavSorter stops trying after the fifth bad file.

Hint: Since files play in the background, you can use this feature as you would a "jukebox." You
can use folders to create "albums" of music or sounds! If you register, you could even use 
WavSorter Pro's support of multiple configurations to create collections of "albums."



Copying the Contents of a Folder
If the default drag operation is copy, then drag the folder containing the files you want to 
copy to another folder and drop it on that folder. If the default drag operation is move, then 
hold down the CTRL key while dragging the folder. Note that you are copying the files in the
folder, not the directory itself.

See: Default Drag Operation



Moving the Contents of a Folder
If the default drag operation is move, then drag the folder containing the files you want to 
move to another folder and drop it on that folder. If the default drag operation is copy, then 
hold down the CTRL key while dragging the folder. Note that you are moving the files in the 
folder, not the directory itself.

See: Default Drag Operation



Deleting the Contents of a Folder
There are two ways to delete the contents of a folder:
· Drag the folder containing the files you want deleted to the Delete   button   and drop it on 

the button.
Or
· Select the folder containing the files you want to delete by clicking on it. Then click on 

the Delete button.
When you drop the folder or click the button, you will be asked if you want to proceed. If 
you want to proceed, you will be given a choice of either confirming the deletion of each file 
or deleting all the files in the directory without confirmation. After all the files have been 
deleted, you will be asked if you want to also delete the directory.

Hint: Since you can confirm the deletion of each file, this is handy way of "weeding" out 
unwanted files. Simply click Yes to delete a file you don't want; click No to keep a file 
you do want.



Displaying Folder Statistics
When you right-click on a folder, WavSorter displays a message box with information about 
the complete path of the directory assigned to that folder, number of files, and size of the 
directory. Cool, huh?



Shortcuts and Techniques
Shortcuts

Double-Clicking
Right-Clicking
Navigating with Folders
Using Magic Target Help

Techniques
Using a Sort Folder
Multi-stage Sorting
Sorting to a Diskette
Using Multiple Configurations
Creating a Custom Drag Icon
Using the OpLight



Double-Clicking
You can play a file by double-clicking on it in the File listbox. It's not necessary to wait for 
one file to stop playing before double-clicking on another.



Right-Clicking
You can display statistics about the currently selected directory or file by right-clicking on it. 
You can right-click on a folder to display statistics even if it's not the currently selected one.



Navigating with Folders
Since selecting a folder causes the Directory listbox to change to the directory assigned to 
that folder, you can navigate your directory structure using folders. For example, instead of 
working your way up and down through directories, simply click on a folder to jump straight 
to the directory assigned to that folder.



Using Magic Target Help
Magic Target Help provides a way for you to learn about an object, button, or menu item 
simply by clicking on it. When you choose Magic Target Help from the Help Menu, the 
cursor becomes a crosshair. Click on something and a popup box provides you with a short 
description. All menu items and buttons, and most objects, respond to Magic Target Help.
Some descriptions also list related topics; click on the related topic hotspot to jump to a full 
topic containing in-depth information. However, there's a quirk in the way Microsoft put 
together Windows Help: the jump to a full topic from one of these little popup topics only 
works if Windows Help is already on the screen. If it's not displayed, nothing happens when 
you click on the jump. You can make sure that Windows Help is displayed by selecting 
Contents from the Help menu before starting Magic Target Help.
When you're finished with Magic Target Help, click on the box that says "Click here when 
done with MT help" and the cursor returns to what it was before Magic Target Help was 
selected.
I'm considering including Magic Target Help in other applications and would appreciate any 
comments or suggestions. Contact me and let me know what you think. Thanks.

Hint: Use Magic Target Help to take a tour of WavSorter. It's a handy way to learn about 
features and how to do things.



Using a Sort Folder
A sort folder allows you to have all your unsorted sound files in one place. This makes 
sorting a lot easier and more efficient.
To create a sort folder:
1. Select a directory you want as the sort directory, or create a new directory and name it 

something appropriate like "unsorted".
2. Assign that directory to a folder and label the folder "Unsorted" or whatever you want to 

call it.
3. Copy or move to that folder all the files you want to sort.
Now, when you want to sort files, just select your sort folder by clicking on it. The files 
contained in that folder will be displayed in the File list box and you can sort by dragging 
them to the appropriate folders.

Hint: When you download sound files, unzip them into your sort directory and they will be 
ready to sort.

See: Edit Folder Window



Multi-Stage Sorting
You can create a group of related folders and save your configuration. When you want to use 
that group, load the configuration which contains it. Multi-stage sorting involves using 
groups of folders to achieve increasingly specific levels of sorting. 
For example, say you have a bunch of animal sounds. You could sort those sounds first into a 
folder labeled "Animals." From there, you could sort them into a group of folders 
representing specific types of animals such as, domestic, farm, and wild. From those folders, 
you could sort the sounds into a group of folders representing specific animals of each type 
such as dogs, cats, and parakeets for domestic animals; pigs, chickens, cows, and goats for 
farm animals; and lions, tigers, and bears for wild animals (Oh my!).

Hint: When you create a group of related folders to use in multi-stage sorting, always include 
in each group a folder representing the next higher level. That way, you can navigate 
straight to the directory you are going to sort from.

See: Multiple Configurations



Sorting to a Diskette
You may have figured this one out for yourself already, but it's worth pointing out anyway: a 
folder can represent a directory on a diskette just as easily it can represent a directory on your
hard disk.
Why is that so wonderful? Well, it means that you can use WavSorter to sort out the clutter of
sound files on your hard disk, by moving sound files to a diskette for archiving. You might 
want to do that with sound files you like, but don't need to have instantly available on your 
hard disk.
Just the sort of thing WavSorter is so good at!



Creating a Custom Icon
Although you can assign any of your icons as the drag icon, you may want to customize it 
first. Using a drag icon that is very large or has a solid background will make it difficult to 
see the object underneath it.
To avoid this problem, use an icon editor (such as Icon Works) to redraw the icon in a smaller
size, if necessary, and make the background transparent.

See: Configuring Drag Icons



Using the OpLight
The OpLight tells you what WavSorter is doing at any given time. When you drag something 
over an object, the OpLight also tells you what action will occur when you drop whatever 
you're dragging onto that object. The OpLight will display "DONE" if the operation was 
successful.
I'm interested in your opinion of this feature because I'm considering including an OpLight in
future programs. Please contact me and let me know what you think. Thanks.



Using the Mouse
Selecting Stuff

Selecting Directories
Selecting Files
Selecting Folders

Drag and Drop
Dragging and Dropping
Default Drag Operation

Getting Information with the Right Mouse Button
Displaying File Statistics
Displaying Directory Statistics
Displaying Folder Statistics



Selecting Directories
To select a directory, single-click on it in the Directory listbox. If the directory you select is 
assigned to a folder, that folder will become highlighted; otherwise, no folder will be 
highlighted.



Selecting Files
To select a file, single-click on it in the File listbox. The complete path of the selected file is 
displayed in the filename panel (just below the Directory listbox).



Selecting Folders
Select a folder by single-clicking on it. If the folder has a directory assigned to it, the 
Directory listbox will change to that directory, and the folder will have a yellow rectangle on 
it. Otherwise, the directory list box doesn't change, and the folder will have a green rectangle 
on it.



Dragging and Dropping
There are three objects in WavSorter that you can drag and drop: directories; files; and 
folders. The object you are dragging is called the source. The destination of your drag and 
drop operation is called the target. There are five targets in WavSorter: the Play File   button  ; 
Play Directory   button  ; folders; Launch   button  ; and Delete   button  ; and folders.
To drag, position the mouse pointer over the source object, press and hold down the left 
mouse button, and drag to the target object. To drop the source object, simply release the 
mouse button. When you are over a target, the OpLight will tell you what operation will be 
performed when you drop the source onto the target.



Displaying File Statistics
Select a file by clicking on it in the File listbox. Once you've selected a file, right-click on it 
to display a message box containing information about that file's size, date and time it was 
last changed or saved, and its attributes.



Displaying Directory Statistics
Select a directory by clicking on it in the Directory listbox. Once you've selected a directory, 
right-click on it to display a message box containing information about the size of the 
directory and the number of files it contains.



Displaying Folder Statistics
Right-click on a folder and a message box appears that provides information about the 
complete path of the directory assigned to that folder, number of files, and size of the 
directory.



Registering WavSorter
You're currently using the evaluation version of WavSorter. It's distributed as shareware, so 
that you can try it out and decide if you want to become a registered user.
When you register WavSorter, you will receive the following benefits:
1. WavSorter Pro 2.1, the advanced version of WavSorter with several very useful 

additional features.
2. Free decimal point (e.g., 2.2, 2.3, 2.4, etc.) maintenance upgrades of    WavSorter Pro for 

six months.
3. Reduced price WavSorter Pro whole number (e.g., 3.0) upgrades.
4. Automatic 15% discount on all other Shepherd Software products.
5. Free technical support.

See: How to Register
Technical Support



How to Register
We've made it easy for you to register by including a registration program (REGISTER.EXE)
with WavSorter. You can register by:
· selecting Register from the Help menu.
· clicking right here on the word REGISTER!

To register, fill in the order form on-screen and then click on the "Print Order" button. Mail 
your order form, along with a check or money order for the appropriate amount to:
Shepherd Software
6984 McKinley St.
Sebastopol, California USA 95472
Same Day Delivery is available for members of CompuServe who use the Standard Pricing 
Plan (communications surcharges, if any, apply); Alternative Pricing Plan members pay the 
normal rates. Next day delivery by United Parcel Service (UPS) is available at extra charge. 
All other orders will be shipped by First Class mail within 48 hours of receipt.
For questions about your order or technical support, please contact me via electronic mail.



Same Day Delivery
If you are a member of CompuServe, you can receive WavSorter Pro 2.1 via Email. This 
method is free of additional charges by CompuServe if you are using the Standard Pricing 
Plan (the one that used to cost $7.95 a month but recently increased to $8.95), although 
communications surcharges, if any, apply. If you don't know whether or not communication 
surcharges apply to you, type GO BILLING on CompuServe to find out. CompuServe 

members who use the Alternative Pricing Plan will naturally be charged by CompuServe for 
whatever rates normally apply.
This delivery service is available from Shepherd Software for $11.00 (US funds) for each 
copy of WavSorter Pro you want delivered this way.
Here's how it works if you don't use WINCIM (it's even easier with WINCIM, of course):
1. WavSorter Pro 2.1 will be sent to you via Email on CompuServe within 24 hours after I 

receive your order..
2. As you log onto CompuServe, if you see the message "You have electronic mail waiting" 

your order has probably arrived; type GO MAIL.
3. At the mail menu, choose "1" to read your messages.
4. You will be notified that "WPRO21.ZIP" is binary.
5. From the menu, choose Download.
6. You will be asked for a filename for your computer; you can use any valid filename you 

want.
7. Proceed with downloading just like you would with any file.
8. When you're finished, delete the message "WPRO21.ZIP" from your mail.
WARNING:
Although you can receive the file WPRO21.ZIP from me since I'm the author, you do not 
have my permission to forward or send it via CompuServe Email to any other person. 
WPRO21.ZIP contains the program WavSorter Pro 2.1 which is copyrighted by Shepherd 
Software (1993). Any unauthorized redistribution by you is strictly prohibited by 
international copyright law and CompuServe and is subject to criminal and civil penalties.



WavSorter Pro
WavSorter Professional has all the features of WavSorter, plus:
· WavSorter Pro plays MIDI files
· WavSorter Pro gives you the ability to create and edit Windows file associations.
· WavSorter Pro gives you the ability to edit the sounds associated with Windows system 

events.
· WavSorter Pro lets you save and utilize a virtually unlimited number of configurations, a 

feature which multiplies the usefulness of WavSorter (see "Using Multiple 
Configurations").

· WavSorter Pro has an expanded help system, that uses more graphics and has a few other 
nice features (I had to keep evaluation version small to save your downloading time).

I've been very careful to structure the WavSorter/WavSorter Pro products so that WavSorter 
has a set of features complete enough to show you its benefits, while providing additional 
features in WavSorter Pro that I believe give you a strong incentive to register.

I'm convinced! I'll Register Now!



Getting Started
What is WavSorter?

Overview
The WavSorter Main Window
The WavSorter Help System
The Philosophy of WavSorter
Acknowledgements

Quick Start
WavSorter Pro



Overview
WavSorter provides an intuitive way to sort sound files. It uses a folder as a metaphor for a 
directory; operations performed on a folder are in reality being performed on the directory 
assigned to it. You can assign directories from any valid drive to a folder.
Once you've assigned directories to the folders, you sort files by dragging them to the 
appropriate folder. Behind the scenes, WavSorter copies or moves the file to the folder's 
directory.
Note that almost everything you see on the screen can respond to dragging and dropping. If 
you're not sure whether an object will perform an operation when something is dropped on it,
drag a directory, file, or folder over it and watch the OpLight for information.



The WavSorter Main Window
You can use this topic as a visual index to the parts of WavSorter.

Menu Bar

File These items let you delete directories; create directories; rename directories; rename files;
delete files; display file statistics; display directory statistics; and exit WavSorter.

Edit With items on the Edit menu, you can edit folder setups, customize various WavSorter 
sound effects and icons, and edit Windows system event sounds and file associations.

Options Options menu items control how WavSorter works: the sound effects and icons 
used, whether dragging is by default a copy or move operation, how statistics are 
displayed, and manage configuration files. (See Configuring WavSorter.)

Help The Help menu is the way you learn about WavSorter, through this help system. (See The
WavSorter Help System.)

Caption
The window caption identifies WavSorter, and lists the name of your current configuration 
file (the example above is using a default configuration, so the configuration is "untitled").

Toolbar
The Toolbar has six buttons that make WavSorter very easy to use. Except for the Exit 
button, you can use these buttons by either clicking on them or dragging an object on to 
them. Click a button name below for more information.

Play File Stop Play Directory

Launch Delete Exit

File Controls
Several controls work together to let you display and select the files on your computer for 



WavSorter to work with.
Drive and Directory listboxes
File Type controls
File listbox
WavSorter displays the name of the currently-selected file in the Filename box.

The File Sorting Area
In the right half of WavSorter's main window you'll find two very important objects; these are
the heart of WavSorter.
The OpLight
Folders



The WavSorter Help System
I've never been too excited by the way most programs use Windows Help (and sometimes 
downright disgusted). Too often, all their help consists of is the printed manual's word 
processor files just dumped into an alleged "help" system, with no attempt at all to exploit the
wonderful possibilities of an online, hypertext system. 
Lame, totally lame.
Novels don't automatically become good movies; they have to be adapted to the strengths and
weakness of a different medium.
Of course, since WavSorter is distributed electronically, I skipped the printed manual entirely,
and was free to use Windows Help to best advantage from the beginning. I think the result is 
actually far more helpful than a printed manual.
It's kind of analogous to the way that you can accomplish a given task in WavSorter several 
ways (for example, you can play a sound file by selecting it and clicking the Play button, you
can double-click the filename, or you can drag the filename over to the Play 
button...everything works). You can find out what you need to know in this help system by 
approaching it from many different directions:
· The traditional way: Select Contents from the Help menu. You get a table of contents, 

from which you can select a major category; from the category table of contents, select a 
specific topic. Use the Back button to move back up, or the >> (Next) or << (Previous) 
buttons to move forward and back through related topics.
This is the only kind of help most programs give you: a hierarchy that's just like those old
textbooks that you found so hard to use in school. If you can't second-guess the author's 
logic for organizing things, you're out of luck.

· You can search a list of keywords by clicking the Search button. This works like an 
index: click on a keyword to display a list of the topics related to that keyword. Use this 
when you think what you're looking for might be related to a word or phrase (such as 
"technical support" or "problems").

· Pressing F1 from the main WavSorter window, or when a dialog box or window is 
displayed, takes you to a topic that describes what you're seeing on the screen.

· And then there's the jewel in the help system crown: Magic Target Help. It started by 
questioning a basic assumption of everybody else's online help: Why the heck should you
have to leave what you're doing, go over to another window (which is really another 
program), search through the help system, and then come back; by which time, in a lot of 
cases, you've forgotten what you were trying to do in the first place! Why can't the 
program itself simply tell you about itself?!
(Sorry, I get a little worked up on the subject). Magic Target Help integrates the 
information you need right into the program's user interface. You turn on Magic Target 
Help on the Help menu, then touch your "magic target" cursor on objects you see on the 
screen; and those objects pop up a little window that explains what they do. In most 
cases, each little popup has a hotspot that will take you to a deeper treatment of the 
subject.



Want to know one reason why commercial software is so expensive? Because software 
companies have to maintain huge support staffs to make up for mediocre manuals and lame 
online help. For some reason, they just don't get it: that putting effort up front into good help 
and documentation saves money down the road with reduced support costs.

A note about the help system with the evaluation version of WavSorter:
I'm pretty sure that the majority of people who get a copy of the evaluation version of 
WavSorter will do so by downloading it from a service such as CompuServe or Windows 
OnLine. When you use those services, every minute costs you, so I decided to include just a 
simplified version of this help system to keep it smaller, and keep your costs down.
The main difference between the two help systems is that the registered version, with 
WavSorter Pro, uses many more graphics--screen captures and diagrams, for example; while 
this version relies more on words. Graphics really send the size of the help file into the 
stratosphere, so I figured that I was doing you a service by leaving them out.
Yep, yet another compelling reason to register!

See: Registering WavSorter



The Philosophy of WavSorter
The idea for WavSorter came about because I had accumulated a lot of .WAV files from 
various BBS's. Unfortunately, Windows doesn't provide any easy way of sorting, let alone 
playing, them. Almost in desperation I thought, "Well, hey, I'll just write a quick little applet 
to sort these buggers." Eight months and many hundreds of hours later, "Viola!"--WavSorter 
is completed...and I'm ready to start sorting. 
It'll be easier for you.
Actually, the product you see now bears little resemblance to my original, fledgling, design. 
Early on, I decided that I wanted to create a program that was not only fun to use but that also
had a friendly appeal; an engaging personality, if you will. This led me to consider the 
appearance of the program and the ways in which the user interacts with it. Along the way, I 
came to a realization which eventually shaped every facet of WavSorter.
I experienced this realization as an image of a VCR sitting placidly on a shelf with its clock 
flashing "12:00" over and over. It occured to me that software is like that VCR: it can 
perform a variety of incredibly complex functions, but only if the user can tell it what to do. 
Everyone can tell their VCR to play, rewind, record, etc., but as soon as they're required to 
perform a series of steps requiring them to interact with it in a less concrete, straightforward 
manner, most people become frustrated and confused. The result is that the clock stays on 
"12:00" and there's a huge market for add-on gadgets that do the VCR programming for you.
From that point on, my goal became creating an interface which was as concrete and as 
straightforward as the buttons on a VCR, and avoid like the plague the obscure user interface 
which prevents you from setting the time on your VCR. The result is an interface which 
appears quite simple but which in fact, behind the scenes, performs a variety of very complex
and complicated tasks. I also provided the ability to customize the interface as much as 
possible to your own personality and taste in the belief that this would further simplify using 
WavSorter. You be the judge: was I successful? Leave me a message and let me know what 
you think.
If I've succeeded in my goals with WavSorter's design, I owe a great deal to my brother, Bob, 
for his assistance and experience in this area. Fortunately for me, Bob took an early    interest 
in the program and helped guide me through the shoals of application design. Bob's 
unrelenting and uncompromising stand that a program's features should, by god, be 
straightforward and make sense to the user kept me from straying too far into the esoteric. 
Without Bob's steadying influence, WavSorter's interface might well have overshot simplicity
and ended up in obscurity. Thanks again, Bob.
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The original line sketches of the dogs were drawn by my friend, Tom 
Danchuk. They are loosely based on Tom's and his wife's own two 
dogs, Mickey and Rascal. Thanks Tom.

The spaceship drag icon and dog face 

on the title screen are based upon icons I downloaded in one of those massive icon 
collections. The toilet sound originally appeared in a mega-collection of sound files I 
downloaded at some forgotten time. None were credited to anyone, nor was there any clue about 
their origins.
My brother, Bob, provided a lot of support, encouragement, and technical assistance. He also 
deserves credit for suggesting several of WavSorter's most nifty features, including the option of 
setting the default drag/drop operation, the ability to assign system sounds from within 
WavSorter, and the features and layout of the Duplicate Files Window. Thanks Bob. (Hey, Bob, I 
have an idea for another cool program.....No, really--it's just an applet.....I promise.)

Jim Shepherd
March 1993

Sebastopol, California

Message from Bob:
Jim forgot to mention that I assembled this help file from material he originated...and that 
means that I get the last word! Ha ha ha ha (can you tell we're brothers?).
He also forgot to acknowledge himself. Jim started the WavSorter project with a simple 
premise: sound and multimedia support in Windows has meant that most people with sound 
boards have managed to accumulate dozens, nay, hundreds, of sound files, from public 
domain sources and sound "clipart" collections (I have a CDROM with several hundred 
clipart sound files, and hundreds more on my hard disk). How do you manage these files? 
WavSorter certainly makes managing sound files easy. But more than that, early on, Jim set 
the goal that WavSorter should be more than just easy: it should support many ways of doing 
things, so that whatever you try, it will probably work. Jim also wanted WavSorter to be 
humorous and fun to use. In fact, he wanted WavSorter to be more than "user-friendly"; he 
wanted it to be likeable and to even have something of a personality.
I've been a computer geek for nigh on fifteen years, and I can tell you: WavSorter is no 
ordinary shareware program. Register this puppy, and give Jim a chance to show his stuff on 
future projects. You will benefit, I guarantee it.
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ordinary shareware program. Register this puppy, and give Jim a chance to show his stuff on 
future projects. You will benefit, I guarantee it.



Quick Start
If you really want to get started right now, these topics will provide you the bare minimum 
you need to know for using WavSorter:
WavSorter Overview
The WavSorter Main Window
Using Magic Target Help
Using the OpLight
Folder Overview
Dragging and Dropping
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The Usual Fine Print
WavSorter and related files, including this help file, are Copyright © 1993 by James Shepherd/Shepherd Software. All rights reserved.
This is the evaluation version of WavSorter. It is distributed as shareware for a 30 day evaluation period. You agree by using this product to either 
register it within 30 days of receipt, or to discontinue using it. Continued use without registration is a violation of Shepherd Software's copyright.

Shepherd Software makes no warranty of any kind with regard to this software or documentation, including, but not limited to, any implied 
warranties of merchantability and fitness for a particular purpose. Shepherd Software shall not be liable for errors or for incidental or consequential 
damages in connection with the furnishing, performance, or use of this product. The software and the information contained in this documentation is
subject to change without notice.



The Usual Fine Print
WavSorter and related files, including this help file, are Copyright © 1993 
by James Shepherd/Shepherd Software. All rights reserved.
This is the evaluation version of WavSorter. It is distributed as shareware 
for a 30 day evaluation period. You agree by using this product to either 
register it within 30 days of receipt, or to discontinue using it. Continued 
use without registration is a violation of Shepherd Software's copyright.
Shepherd Software makes no warranty of any kind with regard to this 
software or documentation, including, but not limited to, any implied 
warranties of merchantability and fitness for a particular purpose. 
Shepherd Software shall not be liable for errors or for incidental or 
consequential damages in connection with the furnishing, performance, or
use of this product. The software and the information contained in this 
documentation is subject to change without notice.



Technical Support
You're currently using the shareware version of WavSorter; it's provided so
that you can evaluate the program and decide whether to register. When 
you register, you receive WavSorter Pro, with additional features.
Registered users underwrite the cost of providing technical support with 
their registration fees. TANSTAAFL is a law of nature. But what should I do 
about supporting people who haven't registered? The hard-line position 
doesn't work: good support for somebody who's evaluating the program 
may make the crucial difference in whether they register. So here's what 
I'm going to do: 
· Unregistered users get support once.
· Please gather all your questions into a single support request; I'll try to 

handle everything at once. Particularly, I want to know about anything 
that's preventing you from using the program, or from having a 
satisfactory experience of the program.

· I also want to hear about your "if only it did this, I'd register" reactions. 
Be assured that I'll take it seriously; Shepherd Software is a business, 
not a hobby, and survives by maximizing registrations.

Send your support request, and I'll respond within 24 hours. Considering 
you haven't even registered yet, that's pretty darn good service!

Electronic Mail
CompuServe: 71664,2255
WindowsOnLineTM (510) 736-8343 

Old-Fashioned Mail
Shepherd Software
6984 McKinley St.
Sebastopol, California USA. 95472

See: Registering WavSorter



TANSTAAFL
There Ain't No Such Thing As A Free Lunch
Coined by Robert Heinlein in his classic work "The Moon is a Harsh 
Mistress." The Universe always balances its books--there's a fixed amount 
of energy and matter around, and what's used over there isn't available to
be used over here.



WavSorter Pro Feature
This is one of the many cool features you'll be able to use once you 
register WavSorter, and receive the registered version, WavSorter Pro.
You bet, I'll Register Now!
Tell me about WavSorter Pro



WavSorter Pro and MIDI Files
You've tried to play a MIDI file with the evaluation version of WavSorter. 
This is one of the many cool features you'll be able to use once you 
register WavSorter, and receive the registered version, WavSorter Pro.
You bet, I'll Register Now!
Tell me about WavSorter Pro



Sound Files



About Sound Files
A sound file contains data that Windows can play through a device such as a sound board. 
Windows defines two standard formats for sound files:
Wave files are recorded sounds; they're a (more or less) accurate record of any sort of sound 
(including noise and other garbage), stored in a digital format, very much like that used to 
record compact discs, that your computer can work with. Wave files are (usually) identified 
by the extension ".WAV" in their filenames.
MIDI files are like sheet music: they contain the notes that one or more computer-
synthesized instruments should play to make music. MIDI files are (usually) identified by the
extension ".MID" in their filenames; sometimes the extension is ".MDI". 

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

You must be using Microsoft Windows 3.1 to take advantage of WavSorter. Windows 3.0 
didn't directly support sound, although many people have added multimedia support through 
CDROM upgrade kits and the like; but 3.0 doesn't support other user interface features used 
by WavSorter, so I cannot guarantee that WavSorter will work under Windows 3.0. (Besides, 
3.1 is enough of an improvement over 3.0 that you'd be crazy not to upgrade.)



System Event Sounds



About System Event Sounds
When you're running Microsoft Windows 3.1 with a sound board, Windows associates a set 
of standard sounds with certain system events. These events are such things as starting or 
exiting Windows, critical errors, and so on; and with the various types of message boxes that 
programs can display. Click here to see some common examples of message boxes and 
message sounds.



System Event Sound Examples
Click on the various boxes below to see examples of the various standard Windows message 
boxes, and the system event sounds associated with each one.

Asterisk Default Stop

Question Exclamation

Note that not all programs ask Windows to play the sound associated with a message box 
type; it's up to the programmer to explicitly include that request.



Folders



About Folders
WaveSorter's folders represent directories. They're active little buggers, constantly changing 
colors and reacting to things you do.
Blue folders are ones you've set up already: they have a valid directory assigned to them, and a 
caption; they're "valid." Gray folders are not yet set up.The various folders, and their meanings:

This is a folder that's been set up, "at rest." That is, you haven't clicked it, nor are you about to drop something 
on it.

This is a valid folder after you've clicked on it; it's the currently-selected folder. The directory and file list boxes
will change to the directory assigned to the folder.

This is a valid folder while you're dragging something over it, but before you've dropped the object. It's open 
and ready to receive.

This is a folder that's not set up, and that's not doing much of anything.

This is a folder that hasn't been set up, after you've clicked on it. This folder is selected (even though it isn't yet 
set up), so that you can assign a directory to it and add a label using Folder on the Edit menu.

This is a folder that isn't set up, when you're dragging a directory name from the directory list box. If you drop 
the directory on this folder, you'll assign the directory to it (and the folder will turn blue!).
See: Working with Folders



Contacting Shepherd Software
Shepherd Software is, well, me (Jim Shepherd). You can reach me in several ways:

Electronic Mail
CompuServe: 71664,2255
WindowsOnLineTM (510) 736-8343 

Old-Fashioned Mail
Shepherd Software
6984 McKinley St.
Sebastopol, California USA. 95472



Shareware



About Shareware
Shareware is not free, nor is it in the public domain; Shepherd Productions retains full 
ownership of the program through its copyright. Rather, shareware is a distribution method 
with some powerful benefits:
· You get to try before you buy. There's nothing more aggravating than spending significant 

money to buy commercial software, only to find it doesn't do what you thought it did, or 
has bugs, or is in some way just not right.

· Shareware costs less, because the price doesn't include fancy packaging, the cost of ads, 
and all the overhead that a commercial company insists you pay for.

What does the shareware author get (besides ulcers and nightmares)? The opportunity to start
a new software company without mortgaging his first-born to a bank or venture capitalists; a 
chance to try out new ideas that big companies are afraid to gamble on; and generally, the 
opportunity to succeed or fail purely on the merits of his imagination and programming skill. 
We all know you could probably get away with cheating, with not registering shareware you 
keep using beyond the 30-day evaluation period. In the long run, you're cheating yourself, 
because if a shareware program turns out to be useful, you have a vested interest in 
supporting the programmer who created it, so that he'll write more programs that will benefit 
you. 
No sermons on morality here, just a direct appeal to your self-interest. Please register.



Drag and Drop



About Drag and Drop
"Drag and drop" is a facility in Windows 3.1 that lets you drag objects from one place on the 
screen to another. Where you drop the object tells a program what you want to do, and what 
you drop tells the program who to do it to.
To drag something:
1. Position the pointer over the object you want to drag.
2. Hold down the left mouse button (and keep it held). The mouse pointer will change 

appearance, indicating that the object supports drag-and-drop (if the pointer remains an 
arrow, you can't drag the object).

3. Move the drag pointer over the object you want to drop on (the destination object that 
performs the action).

4. Release the left mouse button.
See: Dragging and Dropping for more information.



Launch



About "Launch"
The term "launch" is a bit of technojargon that means to start an application.
When I talk about launching a file, I mean that WavSorter gives Windows the name of a file, 
and Windows looks up the application that can work with the file.

See: Launching a File



Associations



About Associations, Associating a File
Windows keeps a table that links filename extensions (such as .WAV) with applications that 
work with each type of file. For example, Windows typically associates the filename 
extension .WAV (a waveform sound file) with the Sound Editor applet; if you double-click on
a .WAV file in File Manager, Windows starts Sound Editor with that .WAV file loaded. (For 
further information, refer to pages 130-132 of your Windows 3.1 User's Guide.)
Some extensions are associated automatically when you install an application. To find out if 
an extension is already associated with an application, try launching the file.

See: Associating a File



Launch Button



About the Launch Button
Once you've associated a file extension, dropping a file with that extension, or selecting a file
with that extension and then clicking this button, launches the associated program with that 
file already loaded. Some programs will launch but will not load a file in this manner. This is 
a limitation of those programs, not of WavSorter. 

Hint: Associate your sound files with your favorite sound editor so that, if your editor supports 
it, you can launch your editor with the file already loaded.

See: Launching Files
Associating a File



Delete Button



About the Delete (Toilet) Button
The Delete button deletes individual files, all files in a directory, or the contents of a folder. 
When you click the button, it deletes the currently-selected file, directory, or folder; or you 
can drag one of those objects onto this button to delete it. If Confirm Deletes is checked on 
the Options Menu, WavSorter will ask you for confirmation before deleting.

See: Dragging and Dropping 
Toilet Sound Effect



Exit Button



About the Exit Button
Clicking this button ends WavSorter; it's the equivalent of selecting Exit from the File Menu 
or double-clicking on the control box. If you've changed your configuration and haven't 
saved the changes to a configuration file, WavSorter will ask you if you want to save your 
configuration.



Play Directory Button



About the Play Directory Button
When you click this button, WaveSorter plays all the sound files in the currently-selected 
directory or folder.
When you drag a directory or folder and drop it on this button, it plays all the sound files in 
that directory or folder.
You can select and play only one directory or folder at a time using the Play Directory button,
although you can use the Play button to queue up multiple individual files to play.

See: About Sound Files
Playing the Files in a Directory



Play File Button



About the Play File Button
Clicking on this button plays the currently selected sound file.
Dragging a filename and dropping it on this button also plays the file.
You can queue up multiple files to be played, by continuing to select files and clicking the 
button, or by dragging and dropping multiple files. WaveSorter remembers the files youve 
selected to play, and plays them in order.
Avoid copying, moving, or deleting a file waiting to be played; obviously, WaveSorter wont 
be able to find a file if its been moved or deleted.

Hint: You can also play a file by double-clicking on it in the file list box.
See: Playing a File

About Sound Files



Stop Button



About the Stop Button
The Stop button tells WavSorter to stop playing the sound file that's currently playing (if no 
sound file is playing, this button is greyed-out and doesn't respond).

See: Playing a File
Playing the Files in a Directory
Playing the Contents of a Folder



The OpLight



About the OpLight
The OpLight is an indicator that tells you what kind of drag and drop operation you're 
currently performing. Because you can configure WavSorter to perform either a copy or 
move by default, it's a good idea to get into the habit of watching the OpLight while you 
drag, to help you avoid mistakes. 
When the operation is complete, the legend changes to "DONE."
I'd be interested to hear your reaction or suggestions about this feature, because I'm 
considering including an OpLight in future programs. Send me a message and let know what 
you think. Thanks.

See: Using the OpLight



File Listbox



About the File Listbox

The File Listbox
(located just 
beneath the File 
Type controls) 
displays the files
in the currently-
selected 
directory or 
folder.

See: File Extension Filter



Directory Listbox



About the Directory and Drive Listboxes

The Directory listbox lets you 
select a directory that becomes 
the current directory for 
WavSorter operations. 

Just above the Directory listbox
is the Drive listbox. When you 
click on its down-arrow, it 
gives you a list of the disk 
drives on your computer. When
you select a new drive, the 
Directory listbox will change to
show the directories on the new
drive.

See: Working with Directories
Using the Mouse



File Type Controls



About the File Type Controls
The File Type controls let you select the type of file displayed in the File listbox; that is, it 
controls the "pattern" of filenames displayed.
This is a "combo box" control, which means that you can either select from a list by clicking 
the down-arrow symbol, or you can type your own directly into the box.

See: File Extension Filter
About the File Listbox




